S bacc50fba0933d6b0c1bb23379d3ca53 undefined method require_gem

# ruby script/server Gem::SourceIndex#search support for String patterns is deprecated
./script/../config/boot.rb:26 is outdated
./script/../config/boot.rb:29: undefined method `require_gem' for main:Object (NoMethodError)
from script/server:2:in `require'
from script/server:2

上記のエラーが出力された場合

該当サーバのgemのバージョンを確認する
0.系と1.系でboot.rbの記述方法が違うので変更する

例)
エラーの出力されている26行目を次の様に修正する
変更前
require_gem

変更後
gem
旧バージョンで表示 ググる ウィキペる 図書る アマゾる つべる ニコる ヤフオクる 英辞る ツイーターで探す

もしかして

    他の人の「undefined method require_gem」

    S bacc50fba0933d6b0c1bb23379d3ca53

    最新

      最新エントリ

        関連ツイート